TuxMobil
site map · index a-z · search   





Resources

· Wholesale Cell Phone Accessories on DHgate.com




Linux on the MICRO\CE Gempower 486S/25 Laptop



The manufacturer label on the case reads Micro Computer Engineering - MICRO\CE and the machine name is Gempower 486S/25 - Advanced Micro Devices - AMD 486, FCC ID ID: HLOGP391C25, built around 1993.

It features a 486 Cyrix CPU (although it says AMD on a sticker at the outside of the case, it says Cyrix in the inside on the label at the chip), 4MB RAM, 163MB HDD and a mono display. The BIOS is made by AWARD. Floppy 1.44MB and power supply are external. The machines weight is app. 1.5kg (external accessories included). There is no PCI.

Floppy Problems

Any boot from Floppy (HAL91, muLinux) failed. I got this message:

pci_init: no BIOS32 detected
unknown interrupt
unknown interrupt
Calibrating delay loop..

There seems to be a problem with kernel 2.0.x, which could be verified later when trying a 2.0.38 kernel from Debian. Building a custom 2.0.39 failed, because the toolchain for building (Debian Woody) was too new for it. *g*

Harddisk Problems

One really big problem was the geometry of the harddisk. Since there is no CD-ROM drive attached to at and my host computer does not have a floppy, I chose to take the harddisk out of the Gempower and into an external case for connecting it via PCMCIA with the host computer.
Now here comes the problem: the Linux on the host saw a 163 GB harddisk while the Gempower saw a 200 GB harddisk. Well, LiLo did not like that and said good-bye with a promising "40 40 40 ..." or "01 01 01 ..." at the first stage. Fortunately GNU grub works well.
This was fine until I got an operating system on the harddisk and tried booting it on the Gempower. EXT2 encountered some "short read" failures when initialising the root partition. fsck went well, mount could mount the partition too, though it never appeared the partition list when invoking mount withouth arguments. Strangely, the whole filesystem was useable.
Afterwards, I tried to partition from the somewhat-running system on the Gempower which resulted in the very same error as seen above when mounting the partition on my host computer.
So finally, the solution was to create a minimal system/partitioning on the harddisk when connected to the host. Then I had to modify the harddisk type in the BIOS of the Gempower to match 163MB, the closest type was 161MB. Now partition the disk on the laptop with fdisk from the minimal system and put it back into the external case to start installing the real system.

Installation

First, I have taken SmallLinux which seemed to work. But it really was too small for the vast 163MB and I did not want to compile every other package on the Gempower, thus looked further.
After trying several mini-distributions (PeeWee, Trinux, Tomsrbt, ClieLinux, Vector), I decided on Debian: a known system which does not try to re-arrange the whole directory structure in a weird way as some of the aforementioned distris do.
For a start, I tried Woody, but reverted to Potato which seemed to have a slightly smaller memory footprint (remember: 4MB RAM). Long live debootstrap and chroot. But the real bummer was a custom 2.2.20 kernel, which took the startup time down from 10 minutes to 2, because the kernel now uses 1 MB RAM less. I had to build a custom one anyway in order to get PCMCIA working.
The system is useable (even networking via PCMCIA), but still awfully slow when installing packages via apt-get. So perhaps it is advisable to try an older distribution like Ham, which perhaps works with libc5, though I never used it before.

Some more hints can be found there:
Getting Linux into Small Machines - HOWTO by L.C. Benschop. Also Bruce Richardson has written a HOWTO on installing a modern Linux distribution (specifically Slackware 7.0) on to laptops with 4MB RAM and <= 200MB hard disks. And I will give Vector Linux a try, beccause this distribution is also targeted to computers with small resources.

PCMCIA

You have to use the driver tcic.

Console / X11

Neither framebuffer nor X11 (4MB RAM!) was tried. The standard resolution of 80x24 works. :)

Sound

There seems to be no sound chip in it. Did not see one when opening the case.

IrDA

Does not exist.

APM / ACPI

Both do not exist. Though the screen is blanked after a couple of minutes when not used and the harddisk is spun down.

Other Resources

Credits

  • Sebastian Henschel







print · i-mode · WAP · PDA
contact · imprint · privacy (P3P) · sponsors · RSS

© Werner Heuser 1997-2013 · http://tuxmobil.org/micro_ce_gempower.html · last change Mon Nov 12 2007