TuxMobil
site map · index a-z · search   





Linux on the Fujitsu-Siemens 270 DX Laptop



Hardware

This LifeBook is about 3 to 4 years old - I bought it from an Ebay auction. It is equipped with:
- Pentium 200 MMX
- 64 MB RAM
- 2.1 GB HDD
- 11.3" TFT Display, 2 MB Video RAM (Trident Cyber chipset)
- Floppy and CD-ROM drives (swapable)
- Interfaces: Sound, USB, PS/2 mouse/keyboard, video out, parallel port, IrDA, 2xPCMCIA

The BIOS is capable of APM and ACPI - I turned off ACPI as both are mutually exclusive in the 2.4-series kernel. APM works much better than ACPI, too.

Linux Distribution

I installed Red Hat 8 as well as Mandrake 9 - both were brand new at the time of writing this (October 9th, 2002). After trying both I am now using Red Hat 8, but any modern Linux distribution will do fine - the LifeBook is quite a good choice with Linux, no problem with all the hardware and features (given a recent 2.4-series kernel). Using Debian Woody or Slackware should not be a problem.

Installation

Installation took ultra-long - it seems the CD-ROM did not like my CD-Rs... A "normal" installation of Red Hat 8 lasts about 20 minutes while on the LifeBook there was enough time to watch 2 movies (it took about 3 hours). I am talking about Red Hat 8 in the following parts; Mandrake was very similar overall.

Anaconda (the Red Hat installer) probed the hardware and loaded up fine. It did not detect sound and the X11 driver produces a bit garbage on screen (Trident "tgui" driver). That's not a problem, however. I installed a basic "personal" system with Gnome2 and OpenOffice (as doing some "real work" with OO is hard when you only have 64MB RAM, I installed the "blackbox" window manager, which does not come included with Red Hat 8. Look at Fresh RPMs).
After 3 hours the system was booting, loading the pcmcia subsystem, the APM daemon and some other laptop-specific things. Now comes a bit of manual tweaking...

X11 Configuration

The driver probed & loaded by Red Hat produces some visual garbage ("trident tgui"). I switched to the unaccelerated "VESA" driver. It is not fast, but anyway, it works and the laptop is too slow to watch movies or play games, so no problem here. Display works only in 800x600 mode. You can choose if you want 16 or 24 bpp - I am using 16 as it appears to be much faster (no surprise, only two-thirds of the pixel data...).
Here is the complete XF86config:

Section "ServerLayout"
        Identifier "Anaconda configured"
        Screen  0       "Screen0"       0       0
        InputDevice     "Mouse0"        "CorePointer"
        InputDevice     "Mouse1"        "SendCoreEvents"
        InputDevice     "Keyboard0"     "CoreKeyboard"
EndSection

Section "Files"
        RgbPath  "/usr/X11R6/lib/X11/rgb"
        FontPath "unix/:7100"
Endsection

Section "Module"
        Load "dbe"
        Load "extmod"
        Load "fbdevhw"
        Load "dri"
        Load "glx"
        Load "record"
        Load "freetype"
        Load "type1"
EndSection

Section "InputDevice"
        Identifier "Keyboard0"
        Driver     "keyboard"
        Option  "XkbRules"      "xfree86"
        Option  "XkbModel"      "pc102"
        Option  "XkbLayout"     "de"
        Option  "XkbVariant"    "nodeadkeys"
EndSection

Section "InputDevice"
        Identifier "mouse0"
        Driver  "mouse"
        Option  "Protocol"      "PS/2"
        Option  "Device"        "/dev/psaux"
        Option  "Emulate3Buttons"       "yes"
EndSection

Section "InputDevice"
        Identifier "mouse1"
        Driver  "mouse"
        Option  "Device"        "/dev/input/mice"
        Option  "Protocol"      "IMPS/2"
        Option  "ZAxisMapping"  "4 5"
EndSection

Section "Monitor"
        Identifier "Monitor0"
        HorizSync 31.5 - 37.9
        VertRefresh 40.0 - 70.0
        Option "dpms"
EndSection

Section "Device"
        Identifier "VESA driver"
        Driver "vesa"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device "VESA driver
        Monitor "Monitor0"
        DefaultDepth    16
        SubSection "Display"
                Depth 16
                Modes "800x600" "640x480"
        EndSubSection
EndSection

External Display: you can switch between Internal onyl/External only/both with Function-F10. This works perfectly so can use this laptop for doing presentations or working in office (using a real big monitor).
External USB mouse: you may have noticed that there are two core pointers defined in the XF86config above. You can plug in a USB mouse any time and it will work immediately. Thats very nice - no reboot or X11 restart necessary! I have not tested plugging in a PS/2 mouse - however, you can set up in the BIOS what should happen (like turning off the integrated trackpoint). That might work as the device should not change (/dev/psaux)...

Want to Have Nice Fonts?

Instead of relying on gray-scale antialiasing, you can use sub-pixel sampling, which greatly improves font rendering!
With Red Hat 8, just open the preferences (Nautilus: "preferences:"), click "Fonts" and then switch to sub-pixel sampling. The effect should become visible immediately. Run "xmag" to zoom in on your desktop - you should see colored borders around your fonts when using sub-pixel sampling, and gray borders when using "normal" antialiasing.

With other distributions there are no visual tools I know of, but it is very easy, too: find the file called XftConfig (often located: /etc/X11/XftConfig) and add just one line:
edit match rgba=rgb;
Thats it.
Using TrueType fonts is a very good idea. Drop them in ~/.fonts/ (Red Hat only!) or in the FontPath for TTF fonts (like /usr/X11/lib/X11/fonts/TTF or something like this).

Sound Configuration

The soundcard was not detected by Anaconda. However, things are easy as you can set IO, IRQ and DMA in the BIOS. The chipset is perfectly SB compatible.
In /etc/modules.conf add these 2 lines:

alias sound-slot-0 sb
options sb io=0x220 irq=5 dma=1

And there you go, sound immediately works within Gnome or XMMS (choose "OSS" output).

USB

Works right up from the point of installation. No problems here. If configuring manually (i.e. when using Debian), be sure to load the right module, it is usb-uhci. Do a
modprobe usb-uhci
and you are fine.

PCMCIA

Works immediatly after installation. I don't own any PCMCIA cards yet, so I cannot tell if they work. Should not be a problem, though. Load the pcmcia services and run the cardmgr, and everything is fine.

Power Management (APM)

Now that's an interesting one!
As I disabled ACPI in the BIOS, APM seems to work very well on this laptop model!
You can close the Laptop any time and it will immediately suspend to RAM. Open it again, and it will resume. Works within X11, and even works when XMMS is just playing some MP3s. It is truely amazing: suddenly XMMS stops, the harddisk powers down, everything is quiet.
Open the laptopn, and the disk powers up, display comes alive and XMMS continues to play as if it never had stopped... Wow! :-)

However, I never managed to get "Suspend to disk" working... Seems you need a FAT16 (?) partition at the beginning or at the end of the disk.
Using the apm commands does not work either: apm -S does nothing, and apm -s suspends the laptop, but it will never wake up...
Thats no big deal, as I said: just close the laptop and it will suspend to RAM and wake up when needed.

One Lithium-Ion pack is sufficient for:
- approximately 5 hours sleep (suspend to RAM)
- or about 1,5 hours running (doing work, playing MP3s)
Thats not too well, but the laptop is old, and it is enough to do some work or do a presentation...

IrDA

Worked fine on Mandrake 9, Red Hat did not detect it so it did not load the irda service. You can change that manually, of course. No further testing conducted.

Working with Office, Optimization, Tweaking, ...

It is not too comfortable to work with OpenOffice on a system with just 64MB RAM. I installed the blackbox window manager, so there is at least some free RAM for Writer, Calc and Inpress.
After starting X11 and Gnome2, all 64 MB are in use and about 15 MB swap space is used, too. With blackbox, about 50 MB are used, but OpenOffice is still slow.

Harddisk is working in Multiword-DMA mode. It is the fastest mode available, no room for further manual tweaking with hdparm. Chipset seems to be a PIIX, perhaps a faster disk with UDMA capabilities would improve performance.

I installed MPlayer (from fresh rpms), and though a P1-200MMX is definately NOT sufficient to watch movies, is was possible to play some MPEGs at reasonable speed (a few framedrops, but at least sound was quite good!). The XVideo extension does not work at 16 bpp, at 24 bpp it worked but was unusable slow.

Thanks to Tuxmobil.org for making such a great site - it definetely helps deciding which laptop to buy. Thanks for all the HOWTOs and to everyone contributing her or his time to help others.
This text may freely be copied, redistributed or modified without written permission.

Other Resources

This page is a courtesy for TuxMobil made by Henne <cambrium_at_gmx.net>.








print · i-mode · WAP · PDA
contact · imprint · privacy (P3P) · sponsors · RSS

© Werner Heuser 1997-2014 · http://tuxmobil.org/fujitsu_siemens_270dx.html · last change Mon Nov 12 2007